Terug naar overzicht
Opgelost

Meta is offline

Jul 24, 2026 at 4:14pm UTC
Getroffen services
Meta

Opgelost
Jul 24, 2026 at 4:19pm UTC

Meta is hersteld.

Aangemaakt
Jul 24, 2026 at 4:14pm UTC

Meta is offline gegaan.