Terug naar overzicht
Opgelost

Meta is offline

Jul 20, 2026 at 1:26pm UTC
Getroffen services
Meta

Opgelost
Jul 20, 2026 at 7:46pm UTC

Meta is hersteld.

Bijgewerkt
Jul 20, 2026 at 7:41pm UTC

Meta is offline gegaan.

Bijgewerkt
Jul 20, 2026 at 1:34pm UTC

Meta is hersteld.

Aangemaakt
Jul 20, 2026 at 1:26pm UTC

Meta is offline gegaan.